13 мая 2015 г.

Решаем проблему установки Steam на Ubuntu 14.04

При установке клиента Steam на версию Ubuntu 14.04.2 64-битной редакции (amd64) может возникнуть ошибка зависимостей пакетов, на подобии такой:

Пакеты, имеющие неудовлетворённые зависимости:
libgl1-mesa-glx:i386 : Зависит: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4)
                        Рекомендует: libgl1-mesa-dri:i386 (>= 7.2)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Это связано с тем, что при установке убунту версии равной 14.04.2 или выше, устанавливается графический стек от более поздней редакции (на данный момент от версии 14.10 15.10).

Чтобы избавиться от ошибок, установим необходимые пакеты вручную. Для этого откроем терминал и введем:

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386

После установки пакетов, steam должен без проблем запуститься и начать скачивать файлы или запуститься, если такие уже имеются в домашней директории.

Update:
В выпусках 14.04.3 и 14.04.4 так же обновился графический стек (от версий 15.04 и 15.10 соответственно), поэтому актуальные команды будут выглядеть следующим образом.
Для стека от версии 15.04 (14.04.3):

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid:i386

Для стека от версии 15.10 (14.04.4):

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-wily:i386 libgl1-mesa-glx-lts-wily:i386

Если будут какие-то другие проблемы, пишите в комментарии.

1 комментарий:

  1. При выполнении команды получаю следующий код.

    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    compiz-plugins-default : Зависит: libgl1-mesa-glx или
    libgl1
    gnome-session-bin : Зависит: libgl1-mesa-glx или
    libgl1
    indicator-bluetooth : Зависит: unity-control-center но он не будет установлен или
    gnome-control-center но он не будет установлен или
    ubuntu-system-settings но он не будет установлен
    libgl1-mesa-dri-lts-utopic:i386 : Конфликтует: libgl1-mesa-dri
    libgl1-mesa-glx-lts-utopic:i386 : Зависит: libglapi-mesa-lts-utopic:i386 (= 10.3.2-0ubuntu1~trusty2) но он не будет установлен
    libglew1.10 : Зависит: libgl1-mesa-glx или
    libgl1
    libglu1-mesa : Зависит: libgl1-mesa-glx или
    libgl1
    libgnome-desktop-3-7 : Зависит: libgl1-mesa-glx или
    libgl1
    libqt5gui5 : Зависит: libgl1-mesa-glx или
    libgl1
    libqt5quick5 : Зависит: libgl1-mesa-glx или
    libgl1
    libwebkitgtk-3.0-0 : Зависит: libgl1-mesa-glx или
    libgl1
    signon-plugin-oauth2 : Зависит: signon-ui но он не будет установлен
    E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.

    ОтветитьУдалить